aboutsummaryrefslogtreecommitdiffstats
path: root/src/libosmo-gtlv/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libosmo-gtlv/Makefile.am')
-rw-r--r--src/libosmo-gtlv/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/src/libosmo-gtlv/Makefile.am b/src/libosmo-gtlv/Makefile.am
index 248ff67..1c40386 100644
--- a/src/libosmo-gtlv/Makefile.am
+++ b/src/libosmo-gtlv/Makefile.am
@@ -16,12 +16,19 @@ AM_LDFLAGS = \
$(COVERAGE_LDFLAGS) \
$(NULL)
-noinst_LIBRARIES = \
- libosmo-gtlv.a \
+lib_LTLIBRARIES = \
+ libosmo-gtlv.la \
$(NULL)
-libosmo_gtlv_a_SOURCES = \
+libosmo_gtlv_la_SOURCES = \
gtlv.c \
gtlv_dec_enc.c \
gtlv_gen.c \
$(NULL)
+
+# This is _NOT_ the library release version, it's an API version.
+# Please read Chapter 6 "Library interface versions" of the libtool
+# documentation before making any modification
+LIBVERSION=1:0:0
+
+libosmo_gtlv_la_LDFLAGS = -version-info $(LIBVERSION) -no-undefined -export-symbols-regex '^osmo_'