aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog37
-rw-r--r--debian/control14
-rw-r--r--debian/libosmo-gtlv1.install (renamed from debian/libosmo-gtlv0.install)0
-rwxr-xr-xdebian/rules2
4 files changed, 45 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 453bc6e..ecac7cd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,40 @@
+libosmo-pfcp (0.2.0) unstable; urgency=medium
+
+ [ Neels Hofmeyr ]
+ * pfcp_msg: check use count correctness
+ * gtlv: check memory bounds 1/3: encoding TLV
+ * gtlv: check memory bounds 2/3: decoding TLV
+ * gtlv: check memory bounds 3/3: encoding to str
+ * gtlv: fix repeated IEIs to several struct members
+ * gtlv: test repeated IEIs to several struct members
+
+ [ Harald Welte ]
+ * Support building with -Werror=strict-prototypes / -Werror=old-style-definition
+ * Add -Werror=implicit-int -Werror=int-conversion -Werror=old-style-definition
+
+ [ Vadim Yanitskiy ]
+ * contrib/jenkins.sh: build with --enable-werror
+ * tests: use 'check_PROGRAMS' instead of 'noinst_PROGRAMS'
+
+ [ Neels Janosch Hofmeyr ]
+ * api doc: explain heartbeat handling in rx_msg_cb
+ * pfcp_test: init logging, for PFCP errors
+ * pfcp_test: add missing 'pdi_present = true'
+ * pfcp_test: fix order of dependencies
+ * PFCP: add Network Instance IE in PDI IE
+ * add osmo_pfcp_ip_addrs_to_str_*()
+ * osmo_pfcp_ip_addrs_set(): do not set port number
+ * add osmo_pfcp_ie_outer_header_creation_to_str_*()
+ * tweak comment in pfcp_ies_custom.c
+ * pfcp coding errmsgs: drop extra newlines
+ * fix coding of Network Instance IE
+ * fix coding of Node ID: FQDN type
+ * bitmask to string: shorten
+ * gtlv: decoding error: log size limited hexdump of IE
+ * silence compiler warning in gtlv_dec_enc.c
+
+ -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 07 Feb 2023 13:58:41 +0100
+
libosmo-pfcp (0.1.2) unstable; urgency=medium
[ Neels Hofmeyr ]
diff --git a/debian/control b/debian/control
index 1d4822d..898d32d 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,7 @@ Build-Depends: debhelper (>=10),
automake,
libtool,
pkg-config,
- libosmocore-dev (>= 1.7.0),
+ libosmocore-dev (>= 1.8.0),
libtalloc-dev (>= 2.1.0)
Standards-Version: 3.9.8
Vcs-Git: https://gitea.osmocom.org/osmocom/libosmo-pfcp
@@ -22,12 +22,12 @@ Section: libs
Architecture: any
Multi-Arch: foreign
Depends: ${misc:Depends},
- libosmo-gtlv0 (= ${binary:Version}),
+ libosmo-gtlv1 (= ${binary:Version}),
libosmo-pfcp0 (= ${binary:Version})
Description: Osmocom PFCP protocol implementation (metapackage)
Install Osmocom PFCP and generic TLV protocol libraries.
-Package: libosmo-gtlv0
+Package: libosmo-gtlv1
Section: libs
Architecture: any
Multi-Arch: same
@@ -43,8 +43,8 @@ Architecture: any
Multi-Arch: same
Section: libdevel
Depends: ${misc:Depends},
- libosmo-gtlv0 (= ${binary:Version}),
- libosmocore-dev (>= 1.7.0),
+ libosmo-gtlv1 (= ${binary:Version}),
+ libosmocore-dev (>= 1.8.0),
libtalloc-dev (>= 2.1.0)
Description: Development files for libosmo-gtlv
libosmo-gtlv implements decoding, encoding and logging of protocols using a
@@ -57,7 +57,7 @@ Multi-Arch: same
Section: debug
Priority: extra
Depends: ${misc:Depends},
- libosmo-gtlv0 (= ${binary:Version})
+ libosmo-gtlv1 (= ${binary:Version})
Description: Debug symbols for libosmo-gtlv
libosmo-gtlv implements decoding, encoding and logging of protocols using a
Tag-Length-Value and/or Tag-Length-Instance-Value structure. This package in
@@ -69,7 +69,7 @@ Architecture: any
Multi-Arch: same
Depends: ${shlibs:Depends},
${misc:Depends},
- libosmo-gtlv0 (= ${binary:Version})
+ libosmo-gtlv1 (= ${binary:Version})
Pre-Depends: ${misc:Pre-Depends}
Description: PFCP protocol support
Decoding, encoding and endpoint implementation of the Packet Forwarding Control Protocol
diff --git a/debian/libosmo-gtlv0.install b/debian/libosmo-gtlv1.install
index dba9905..dba9905 100644
--- a/debian/libosmo-gtlv0.install
+++ b/debian/libosmo-gtlv1.install
diff --git a/debian/rules b/debian/rules
index e32eb67..7b522af 100755
--- a/debian/rules
+++ b/debian/rules
@@ -55,7 +55,7 @@ override_dh_auto_configure:
# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
override_dh_strip:
- dh_strip -plibosmo-gtlv0 --dbg-package=libosmo-gtlv-dbg
+ dh_strip -plibosmo-gtlv1 --dbg-package=libosmo-gtlv-dbg
dh_strip -plibosmo-pfcp0 --dbg-package=libosmo-pfcp-dbg
# Print test results in case of a failure