summaryrefslogtreecommitdiffstats
path: root/src/router/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/router/Makefile.am')
-rw-r--r--src/router/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/router/Makefile.am b/src/router/Makefile.am
new file mode 100644
index 0000000..e7d9384
--- /dev/null
+++ b/src/router/Makefile.am
@@ -0,0 +1,26 @@
+AM_CPPFLAGS = -Wall -Wextra -g $(all_includes)
+
+bin_PROGRAMS = \
+ osmo-cc-router
+
+osmo_cc_router_SOURCES = \
+ call.c \
+ routing.c \
+ audio.c \
+ display_status.c \
+ main.c
+
+osmo_cc_router_LDADD = \
+ $(COMMON_LA) \
+ ../libdebug/libdebug.a \
+ ../liboptions/liboptions.a \
+ ../libsample/libsample.a \
+ ../libtimer/libtimer.a \
+ ../libjitter/libjitter.a \
+ ../libosmocc/libosmocc.a \
+ ../libg711/libg711.a \
+ ../libdtmf/libdtmf.a \
+ ../libfm/libfm.a \
+ ../libfilter/libfilter.a \
+ ../libwave/libwave.a
+