summaryrefslogtreecommitdiffstats
path: root/src/telephone/Makefile.am
diff options
context:
space:
mode:
authorAndreas Eversberg <jolly@eversberg.eu>2021-03-13 17:09:20 +0100
committerAndreas Eversberg <jolly@eversberg.eu>2021-03-21 09:03:06 +0100
commit72b0d35e6c52a13f133e26b74b2414cf94fbc8e8 (patch)
tree6e3f9cb11fd0a748436b4e711979473d97508324 /src/telephone/Makefile.am
Initial commit
Diffstat (limited to 'src/telephone/Makefile.am')
-rw-r--r--src/telephone/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/telephone/Makefile.am b/src/telephone/Makefile.am
new file mode 100644
index 0000000..e850614
--- /dev/null
+++ b/src/telephone/Makefile.am
@@ -0,0 +1,30 @@
+AM_CPPFLAGS = -Wall -Wextra -g $(all_includes)
+
+bin_PROGRAMS = \
+ osmo-cc-alsa-endpoint
+
+osmo_cc_alsa_endpoint_SOURCES = \
+ telephone.c \
+ main.c
+
+osmo_cc_alsa_endpoint_LDADD = \
+ $(COMMON_LA) \
+ ../libdebug/libdebug.a \
+ ../liboptions/liboptions.a \
+ ../libsample/libsample.a \
+ ../libsamplerate/libsamplerate.a \
+ ../libfilter/libfilter.a \
+ ../libtimer/libtimer.a \
+ ../libjitter/libjitter.a \
+ ../libosmocc/libosmocc.a \
+ ../libg711/libg711.a \
+ -lm
+
+if HAVE_ALSA
+AM_CPPFLAGS += -DHAVE_ALSA
+
+osmo_cc_alsa_endpoint_LDADD += \
+ ../libsound/libsound.a \
+ $(ALSA_LIBS)
+endif
+