aboutsummaryrefslogtreecommitdiffstats
path: root/debian/control
AgeCommit message (Collapse)AuthorFilesLines
2020-01-03Bump version: 1.5.0.91-5997-dirty → 1.6.01.6.0Pau Espin Pedrol1-2/+2
Change-Id: I99e6950db3f54c6291dd259bed9b5c46cc26c465
2019-08-08Require newer versions of dependenciesPau Espin Pedrol1-11/+11
New APIs only available since libgtp 1.4.0 are needed, and in turn that libgtp version requires newer libosmocore 1.1.0. osmo-sgsn itself requires libosmocore 1.2.0 since it uses GSM23003_TMSI_SGSN_MASK. Change-Id: I1c67d3e7dda093b4869756c7a63dc7a4549084ae
2019-05-29debian: create -doc subpackage with pdf manualsOliver Smith1-1/+11
I have verified, that the resulting debian packages build in my own OBS namespace (see the -doc packages): https://download.opensuse.org/repositories/home:/osmith42/Debian_9.0/all/ https://build.opensuse.org/project/show/home:osmith42 Depends: Ib7251cca9116151e473798879375cd5eb48ff3ad (osmo-ci) Related: OS#3899 Change-Id: I9c09a0cb5c65fa2e2cd9817edb4656b2a1a35bb9
2018-10-30Remove local libgsupclient; Use libosmo-gsup-client from osmo-hlrHarald Welte1-1/+2
osmo-hlr has recently (as of Change-Id Iad227bb477d64da30dd6bfbbe1bd0c0a55be9474) a working shared library implementation of libosmo-gsup-client. We can remove the local implementation in osmo-sgsn and use the system-installed shared library instead. Change-Id: I6f542945403cf2e3ddac419186b09ec0e2d43b69
2018-09-14debian: add missing build dependenciesAlexander Couzens1-0/+2
Change-Id: I0d552f938224e553187f0b4da06eac90fc025c95
2018-09-13Install systemd services with autotoolsPau Espin Pedrol1-0/+1
Change-Id: I103bf3468d53578045593eac31b61f7e0248495e
2017-12-27Migrate from OpenSSL to osmo_get_rand_id()Max1-1/+0
This avoids potential licensing incompatibility and makes integration of Debian packaging patches easier. The libosmocore version requirements are fine already but for jenkins tests to pass we have to have Ic77866ce65acf524b768882c751a4f9c0635740b merged into libosmocore master. Related: OS#1694 Change-Id: I2b687b7f07ef05bbd861b8479cad5a958a3dde92
2017-09-25Remove unneeded dep libdbiPau Espin Pedrol1-2/+0
This dependency is not needed and it's most probably a left over from openbsc git repository split. Change-Id: I84b0e2851dc89dca39e87215c71e93457acb884f
2017-09-06debian: fix osmo-sgsn.install, tweak VCS link and descriptionsNeels Hofmeyr1-10/+4
Change-Id: I6493a7ca7d996fab00d99652a74a709c860a3de7
2017-08-30rework /debian support to match new osmo-sgsnAlexander Couzens1-149/+42
Remove old leftover from split of osmo-sgsn out of openbsc. Change-Id: Ic0135a1118a115e8f053154e280f60674390f43a
2017-01-30debian: Require libgtp-dev after the SO version bumpHolger Hans Peter Freyther1-1/+1
The ABI of libgtp changed and we require a new library now. Drop the SO_VERSION from the library name and just depend on libgtp-dev. Change-Id: Ib301b27e2c08fda827b55820389247e27e5e8fc7
2017-01-24debian: Install header and source file to different directoryHolger Hans Peter Freyther1-2/+2
osmo-bts consumes the gsm_data_shared.{h,c} files and assumes the OpenBSC directory layout. Install the files into the specific sub-directories to make the --with-openbsc=dir option work. Change-Id: I3da21402dee3d6f1d812b232b0a3f13b8a462d5b
2017-01-21Turn some compiler warnings into errorsMax1-0/+1
Re-apply the reverted commit 98bc7fa50d0731864297f8fb82932d480c426ff6, this time with a clear error message in case autoconf-archive is not installed. Change-Id: I631bde22e79ec0318eb9c8114db5861a1d635816 Tweaked-by: Neels Hofmeyr <nhofmeyr@sysmocom.de>
2017-01-19deb: unbreak nightly buildsRuben Undheim1-0/+11
Add openbsc-dev with source and header files necessary for osmo-bts builds. Max's note: extracted from Debian packaging work into separate commit. Change-Id: I25f8c639d2dc525ca280a7cd09de3ca6358d2568
2017-01-13Revert "Turn some warnings into errors"Neels Hofmeyr1-1/+0
This introduces a failure with ./configure on my machine: ../configure: line 6612: syntax error near unexpected token `-Werror=implicit,' ../configure: line 6612: `AX_CHECK_COMPILE_FLAG(-Werror=implicit, CFLAGS="$CFLAGS -Werror=implicit")' Makefile:420: recipe for target 'config.status' failed make[1]: *** [config.status] Error 2 Installing autoconf-archive did not fix the error. So even though jenkins seems to accept this, I cannot build with this patch. Let's find out how to do this in a way that all systems can still build and then re-apply this patch. This reverts commit fd161ccce8ecaad3ddd32dd8b696902e81593ae3. Change-Id: I2b368500b07f233882ef854eca1fa21f6df39e29
2017-01-11Turn some warnings into errorsMax1-0/+1
Make warnings (when available) related to common memory-related issues into errors to harden the source and decrease chance of errors. Change-Id: Ied9c950dafa65f324cf31298b13b590f56139700
2016-12-21Integrate Debian packaging changesMax1-19/+67
debian/control: * restructure to make it easier to incorporate further changes * update package descriptions * update project URL debian/rules: * use proper hardening syntax * restructure to make it easier to incorporate further changes * remove useless comment debian/compat: update compatibility version debian/coryright: update to match Debian format Change-Id: I49cc9239b15dc77d782914ca2547e601d049acdc Related: OS#1694
2015-11-30gtphub: add to debian buildNeels Hofmeyr1-0/+14
By the example of osmo-sgsn, package osmo-gtphub for debian. Sponsored-by: On-Waves ehi
2015-09-04Add SMPP support in the debian build, include libsmpp34-dev as a dependency.Ciaby1-1/+1
2015-08-23debian: Require ares for the SGSN and GGSN resolvingHolger Hans Peter Freyther1-1/+1
2015-08-23debian: Add libssl-dev for the NATHolger Hans Peter Freyther1-1/+1
2015-05-17debian: Fix dependencies pointed out by lintianHolger Hans Peter Freyther1-1/+1
E: openbsc source: missing-separator-between-items in osmocom-nitb depends field between '${misc:Depends}' and 'libdbd-sqlite3'
2015-04-29debian: Do not depend on shared libraries directlyHolger Hans Peter Freyther1-7/+7
The debian shlibs:depends macro will add the depends according to the needed libraries for us. We only need this for the sqlite3 plugin of libdbi-drivers as there is no direct linkage.
2015-04-23debian: meas2pcap requires libpcap-dev unconditionallyHolger Hans Peter Freyther1-1/+1
2015-01-21debian: Fix dependenciesJacob Erlbeck1-2/+2
The dependecies do not match the current package names or are missing: Build-Depends: - renamed libgtp-dev -> libgtp0-dev - added libosmo-netif-dev Depends: - renamed libgtp -> libgtp0 Other run time dependencies might still be missing and have to be installed manually. This is taken from Holger's e744ebd17c3761b5cad81d718d0349f2f820ec66. In addition, the build-dependency on libgtp-dev is replaced by libgtp0-dev.
2014-07-30Fix some packaging mistakes detected by lintian.Max1-0/+7
Signed-off-by: Max Suraev <max.suraev@fairwaves.co>
2013-12-12debian: Build debug packages for each of the target packagesHolger Hans Peter Freyther1-0/+56
2012-11-06debian: Make the package creation work on debian squeeze (stable)Holger Hans Peter Freyther1-1/+1
the dh_autoreconf application did not honor the sourcedirectory option back then. Override the target and call autoreconf from the right directory. The libdbi development package is called libdbi0-dev. Use this name for Debian stable but it should work for Ubuntu as well.
2012-11-06debian: We require libdbi-sqlite3 for running the testsHolger Hans Peter Freyther1-1/+1
The tests are not broken but the db test fails when the dbi driver is not installed. Make it a build time depedency.
2012-11-06debian: Move debian directory to ease building packagesHolger Hans Peter Freyther1-0/+44
This is required to have git-buildpackage be able to create tarballs from the git repository and was done by Jan in the debian branch as well.