aboutsummaryrefslogtreecommitdiffstats
path: root/doc/charts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/charts/Makefile.am')
-rw-r--r--doc/charts/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/doc/charts/Makefile.am b/doc/charts/Makefile.am
index af0736d..99b35f5 100644
--- a/doc/charts/Makefile.am
+++ b/doc/charts/Makefile.am
@@ -19,6 +19,10 @@ $(builddir)/%.png: $(srcdir)/%.msc
$(builddir)/%.png: $(srcdir)/%.dot
dot -Tpng $< > $@
+$(srcdir)/%.msc: $(srcdir)/%.ladder
+ @which ladder_to_msc.py || (echo 'PLEASE POINT YOUR $$PATH AT libosmocore/contrib/ladder_to_msc.py' && false)
+ ladder_to_msc.py -i $< -o $@
+
.PHONY: poll
poll:
while true; do $(MAKE) msc dot; sleep 1; done