aboutsummaryrefslogtreecommitdiffstats
path: root/doc/charts/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2022-01-12 02:35:01 +0100
committerNeels Hofmeyr <neels@hofmeyr.de>2022-06-16 13:04:33 +0200
commit5d8bff6ba05a45627b2af43447b5832165fc0eac (patch)
tree28c91026e8711e702dfdcc80a9d484d91fa87423 /doc/charts/Makefile.am
parentd6ac69d6f6397da8f4d9e2fa0cd4c03ef0a2c06f (diff)
add initial FSM design charts
Diffstat (limited to 'doc/charts/Makefile.am')
-rw-r--r--doc/charts/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/doc/charts/Makefile.am b/doc/charts/Makefile.am
new file mode 100644
index 0000000..af0736d
--- /dev/null
+++ b/doc/charts/Makefile.am
@@ -0,0 +1,24 @@
+msc: \
+ $(builddir)/pfcp_msgs.png \
+ $(builddir)/pfcp_msgs_gtp.png \
+ $(NULL)
+
+dot: \
+ $(builddir)/pfcp_overview.png \
+ $(builddir)/pfcp_cp_peer_fsm.png \
+ $(builddir)/pfcp_up_peer_fsm.png \
+ $(builddir)/pfcp_heartbeat_fsm.png \
+ $(builddir)/pfcp_cp_session_fsm.png \
+ $(builddir)/pfcp_up_session_fsm.png \
+ $(builddir)/pfcp_and_gtp.png \
+ $(NULL)
+
+$(builddir)/%.png: $(srcdir)/%.msc
+ mscgen -T png -o $@ $<
+
+$(builddir)/%.png: $(srcdir)/%.dot
+ dot -Tpng $< > $@
+
+.PHONY: poll
+poll:
+ while true; do $(MAKE) msc dot; sleep 1; done