aboutsummaryrefslogtreecommitdiffstats
path: root/pcap-dlpi.c
diff options
context:
space:
mode:
authorguy <guy>2000-08-13 06:56:05 +0000
committerguy <guy>2000-08-13 06:56:05 +0000
commit5c220490cb9df37386f6d36309c23db663515ec9 (patch)
treeaf9d5d20bff37844eeca88fd1f39b027a40ff9d6 /pcap-dlpi.c
parent64c7184aa634eaf11933c7c11acce258117885c9 (diff)
Change the message issued on HP-UX if we can't find the PPA for a
network device, so that 1) you can infer from the message whether the program is using the old version of the code to get the PPA (which didn't work all that well) or the newer version, without having to prod a user complaining about tcpdump/Ethereal/whatever not working to tell you which version of libpcap they're using; 2) programs can perhaps check the error message returned by libpcap and, if it's the old error message, tell the user that the problem may be that they're using an old libpcap.
Diffstat (limited to 'pcap-dlpi.c')
-rw-r--r--pcap-dlpi.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/pcap-dlpi.c b/pcap-dlpi.c
index cf7615a..958caa5 100644
--- a/pcap-dlpi.c
+++ b/pcap-dlpi.c
@@ -38,7 +38,7 @@
#ifndef lint
static const char rcsid[] =
- "@(#) $Header: /tcpdump/master/libpcap/pcap-dlpi.c,v 1.58 2000-07-11 00:37:05 assar Exp $ (LBL)";
+ "@(#) $Header: /tcpdump/master/libpcap/pcap-dlpi.c,v 1.59 2000-08-13 06:56:05 guy Exp $ (LBL)";
#endif
#ifdef HAVE_CONFIG_H
@@ -908,7 +908,7 @@ get_dlpi_ppa(register int fd, register const char *device, register int unit,
}
if (i == ap->dl_count) {
snprintf(ebuf, PCAP_ERRBUF_SIZE,
- "can't find PPA for %s", device);
+ "can't find /dev/dlpi PPA for %s", device);
return (-1);
}
if (ip->dl_hdw_state == HDW_DEAD) {