aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorBalint Reczey <balint@balintreczey.hu>2015-12-15 17:30:40 +0100
committerAnders Broman <a.broman58@gmail.com>2015-12-16 05:34:22 +0000
commit7ce903bee7b01558361b98e6cd6481ed1e257156 (patch)
treef9f40e54e31f7f132b7a37233182cb9568b47876 /debian/patches
parent04d72727a88f224a80f8bd63640a6889a939729c (diff)
debian: Sync patches with Debian
Change-Id: Iec369a7c5ecd559310198efca2cadb56a449de49 Reviewed-on: https://code.wireshark.org/review/12662 Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/04_asn2wrs_ply.patch7
-rw-r--r--debian/patches/05_note-README-when-running-as-root.patch2
-rw-r--r--debian/patches/06_release-version.patch8
-rwxr-xr-x[-rw-r--r--]debian/patches/08_wireshark-desktop-menu.patch13
-rwxr-xr-x[-rw-r--r--]debian/patches/09_idl2wrs.patch6
-rwxr-xr-x[-rw-r--r--]debian/patches/16_licence_about_location.patch14
-rw-r--r--debian/patches/series6
7 files changed, 42 insertions, 14 deletions
diff --git a/debian/patches/04_asn2wrs_ply.patch b/debian/patches/04_asn2wrs_ply.patch
index 2cf2bae9c9..bc700467c6 100644
--- a/debian/patches/04_asn2wrs_ply.patch
+++ b/debian/patches/04_asn2wrs_ply.patch
@@ -8,10 +8,11 @@ Author: Jakub Wilk <ubanus@users.sf.net>
@@ -70,8 +70,8 @@
import getopt
import traceback
-
+
-import lex
-import yacc
+from ply import lex
+from ply import yacc
-
- from functools import partial
+
+ if sys.version_info[0] < 3:
+ from string import maketrans
diff --git a/debian/patches/05_note-README-when-running-as-root.patch b/debian/patches/05_note-README-when-running-as-root.patch
index 68872b317f..2abed19e97 100644
--- a/debian/patches/05_note-README-when-running-as-root.patch
+++ b/debian/patches/05_note-README-when-running-as-root.patch
@@ -4,7 +4,7 @@ Author: Balint Reczey <balint@balintreczey.hu>
--- a/ui/gtk/main.c
+++ b/ui/gtk/main.c
-@@ -2085,7 +2085,7 @@
+@@ -2102,7 +2102,7 @@
"This could be dangerous.\n\n"
"If you're running Wireshark this way in order to perform live capture, "
"you may want to be aware that there is a better way documented at\n"
diff --git a/debian/patches/06_release-version.patch b/debian/patches/06_release-version.patch
index ee5584fd59..6a0d2fd4d4 100644
--- a/debian/patches/06_release-version.patch
+++ b/debian/patches/06_release-version.patch
@@ -4,12 +4,12 @@ Author: Balint Reczey <balint@balintreczey.hu>
--- a/Makefile.am
+++ b/Makefile.am
-@@ -638,7 +638,7 @@
+@@ -676,7 +676,7 @@
am__v_PERL_0 = @echo " PERL " $@;
am__v_PERL_1 =
-
+
-version.h: FORCE
+version.h:
- $(AM_V_PERL)$(PERL) $(srcdir)/make-version.pl $(srcdir)
-
+ $(AM_V_PERL)$(PERL) $(srcdir)/make-version.pl $(srcdir)
+
#
diff --git a/debian/patches/08_wireshark-desktop-menu.patch b/debian/patches/08_wireshark-desktop-menu.patch
index db6ddd51de..e23a5032cd 100644..100755
--- a/debian/patches/08_wireshark-desktop-menu.patch
+++ b/debian/patches/08_wireshark-desktop-menu.patch
@@ -4,10 +4,19 @@ Author: <fred@candle>
--- a/wireshark.desktop
+++ b/wireshark.desktop
-@@ -75,4 +75,5 @@
- MimeType=application/vnd.tcpdump.pcap;application/x-pcapng;application/x-snoop;application/x-iptrace;application/x-lanalyzer;application/x-nettl;application/x-radcom;application/x-etherpeek;application/x-visualnetworks;application/x-netinstobserver;application/x-5view;
+@@ -108,4 +108,5 @@
+ MimeType=application/vnd.tcpdump.pcap;application/x-pcapng;application/x-snoop;application/x-iptrace;application/x-lanalyzer;application/x-nettl;application/x-radcom;application/x-etherpeek;application/x-visualnetworks;application/x-netinstobserver;application/x-5view;application/x-tektronix-rf5;
# Category entry according to:
# http://standards.freedesktop.org/menu-spec/1.0/
-Categories=System;Monitor;Qt;
+Categories=Network;
+Encoding=UTF-8
+--- a/wireshark-gtk.desktop
++++ b/wireshark-gtk.desktop
+@@ -108,4 +108,5 @@
+ MimeType=application/vnd.tcpdump.pcap;application/x-pcapng;application/x-snoop;application/x-iptrace;application/x-lanalyzer;application/x-nettl;application/x-radcom;application/x-etherpeek;application/x-visualnetworks;application/x-netinstobserver;application/x-5view;application/x-tektronix-rf5;
+ # Category entry according to:
+ # http://standards.freedesktop.org/menu-spec/1.0/
+-Categories=System;Monitor;GTK;
++Categories=Network;
++Encoding=UTF-8
diff --git a/debian/patches/09_idl2wrs.patch b/debian/patches/09_idl2wrs.patch
index f479ba650d..9879ce34c5 100644..100755
--- a/debian/patches/09_idl2wrs.patch
+++ b/debian/patches/09_idl2wrs.patch
@@ -7,7 +7,7 @@ Author: Frederic Peters <fpeters@debian.org>
@@ -65,41 +65,8 @@
exit 1;
fi
-
+
-#
-# Run wireshark backend, looking for wireshark_be.py and wireshark_gen.py
-# in pythons's "site-packages" directory. If cannot find that, then
@@ -31,7 +31,7 @@ Author: Frederic Peters <fpeters@debian.org>
-# set up a valid path.
-
exec omniidl -b wireshark_be $@
-
+
-old code: not reached
-
-echo "idl2wrs Error: Could not find both wireshark_be.py AND wireshark_gen.py."
@@ -43,6 +43,6 @@ Author: Frederic Peters <fpeters@debian.org>
-
-exit 2
-
-
+
#
# Editor modelines - http://www.wireshark.org/tools/modelines.html
diff --git a/debian/patches/16_licence_about_location.patch b/debian/patches/16_licence_about_location.patch
index 36cebffc18..0806d53a52 100644..100755
--- a/debian/patches/16_licence_about_location.patch
+++ b/debian/patches/16_licence_about_location.patch
@@ -4,7 +4,7 @@ Author: Frederic Peters <fpeters@debian.org>
--- a/ui/gtk/about_dlg.c
+++ b/ui/gtk/about_dlg.c
-@@ -506,7 +506,7 @@
+@@ -502,7 +502,7 @@
#if defined(_WIN32)
absolute_path = get_datafile_path("COPYING.txt");
#else
@@ -12,3 +12,15 @@ Author: Frederic Peters <fpeters@debian.org>
+ absolute_path = get_datafile_path("ABOUT.GPL");
#endif
page = text_page_new(absolute_path);
+
+--- a/ui/qt/about_dialog.cpp
++++ b/ui/qt/about_dialog.cpp
+@@ -312,7 +312,7 @@ AboutDialog::AboutDialog(QWidget *parent) :
+ #if defined(_WIN32)
+ f_license.setFileName(get_datafile_path("COPYING.txt"));
+ #else
+- f_license.setFileName(get_datafile_path("COPYING"));
++ f_license.setFileName(get_datafile_path("ABOUT.GPL"));
+ #endif
+
+ f_license.open(QFile::ReadOnly | QFile::Text);
diff --git a/debian/patches/series b/debian/patches/series
index dd30417d28..2224742cb3 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,7 @@
02_use_packaged_openlayers_js.patch
+04_asn2wrs_ply.patch
+05_note-README-when-running-as-root.patch
+06_release-version.patch
+08_wireshark-desktop-menu.patch
+09_idl2wrs.patch
+16_licence_about_location.patch